Home > apple, hackintosh, operating system > 10.5.7 on Hackintosh

10.5.7 on Hackintosh

10.5.7

My main hackintosh is now updated to 10.5.7, using the 10.5.7 update dmg downloaded from the Apple web site. I could have used the Software Update install method which has worked just as well for the past couple of updates, but I have three machines to install on so it makes sense to download once. There appear to be no issues following the update, just the usual replacement of files that the update overwrites.

From experience I now have a short list of files that I take from my backup of the Extensions folder (copied from /System/Library/Extensions before installing 10.5.7).

ALCinject.kext
IOATAFamily.kext
AppleAHCIPort.kext
AppleHDA.kext
AppleRTL8169Ethernet.kext
AppleSMBIOS.kext
IOAHCIFamily.kext

These are the files that work for my hardware and installation. I restore them to the Extensions folder using OSX86Tools, but there are other methods including manual replacement and using Kext Helper.

There were three issues that replacing the files fixed. First was no Audio output, restoring the ALCinject.kext and AppleHDA.kext files took care of that. Next was the system’s failure to recognise my hard drives, instead showing them as generic devices. The image on the left shows the Finder before restoring IOATAFamily.kext, AppleAHCIPort.kext andIOAHCIFamily.kext. The image on the right is after.

Finder_post_10.5.7Finder_replaced_kexts

The final problem was 10.5.7 replacing the modified SMbios file I had recently installed to fix an issue with iMovie and DVD Player crashing when disk images were mounted. Again this was as simple as resoring the original file.

Advertisements
  1. dgan
    June 17, 2009 at 5:51 pm

    Hi all! I need help with a “graphic and hang” problem after updating from 10.5.6 to 10.5.7.

    My system is an amd64 4000+ (sse3 capable), 2gb ram, geforce 6600gt 128mb and sataII seagate 500gb.

    I have three OS X partitions on my pc. One was updated from 10.5.4 (Leo4all v4.1) to 10.5.7 using the updates directly from apple software update and replacing the kernel with a voodoo version.

    The second partition was updated from 10.5.6 (ipc universal ppf5 final) to 10.5.7 using ideneb combo upgrade.

    The last partition was updated from 10.5.6 (ipc universal ppfr5 final) to 10.5.7 using the original apple update (via apple software update without modifications) and replacing the kernel with a voodoo version.

    The 3 partitions are using an efi graphic string and all worked perfect at 10.5.6. When I updated the three to 10.5.7 using the methods mentioned above, the graphics problem began. I mean, when I open preview, (the best way to reproduce the error fast in my tests) and make some window movements with images or pdf files, the mouse cursor freezes with all the screen and after 5 seconds, the mouse begins to move again but the screen remains freezed until I make a restart. The interesting part, is that only happens with video because I continue having sound and activity on my system. Is the video the only part being affected.

    Thanks!

  2. June 23, 2009 at 10:36 pm

    Hi I’m just wondering what versions of those old kexts you’re using are… Thanks!

  3. Stanca
    October 11, 2009 at 5:39 pm

    Why everytime I try to install a hackintosh dvd the mouse cursor is frozen to the disk utilities(installation).It’s because of the mouse?

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: